因為在升級一堆 library 版本
然後踩了一堆雷
然後最令人厭煩的事 google service lib 的版本一直說跟 8.3.0 有衝突
然後完全編譯不過

Please fix the version conflict either by updating the version of the google-services plugin.

官網

解決方案在此

最後竟然是要把

apply plugin: 'com.google.gms.google-services'

放到 app 的 build.gradle 的「最後」,放在最下面
結果就 Build Successful ......

搞了我一天啊!!!

還有順序性的啊?!
這到底是為什麼啊囧!!!

(╯°Д°)╯︵ /(.□ . )

Comments

comments powered by Disqus